Windows 7 - Vista Updates "Window modules installer stopped working and closed

Asked By bullmo on 02-Mar-08 01:02 AM
Vista Premium Home came installed on my Dell desktop about 6 months ago.
Since November 2007, updates hang and will not complete. Some at 15%, others
at 75%. Some will install and others won't complete. Clicking cancel has no
effect. Hard shutdown is the only way to shut down, as the computer continues
to run updates. I really want to keep updates current, but... Any suggestions?




TaurArian replied on 02-Mar-08 05:00 AM
Log on as an Administrator -

Start button || Control Panel ||System and Maintenance ||Administrative Tools

Double-click Services

(Provide the Administrator password or confirmation if prompted to do so.)

Right-click the "Windows Modules Installer" service, and select Properties.

Select General tab - make sure that Startup type is Manual.


--
====================================
TaurArian [MVP] 2005-2008 - Australia
====================================
How to ask a question: http://support.microsoft.com/kb/555375
http://taurarian.mvps.org/index.htm
Emails will not be acknowledged - please post to the newsgroup so all may benefit.
Computer Maintenance: Acronis / Diskeeper / Paragon / Raxco
bullmo replied on 02-Mar-08 01:15 PM
I tried that, and it did not work. I suspect that some updates were installed
out of order. The thing I plan on trying is uninstalling what updates have
installed since the last orderly update and then reinstall in the order of
issue. However where can I find out what order the updates were issued in?
TaurArian replied on 02-Mar-08 03:34 PM
You could try the catalog -
http://catalog.update.microsoft.com/v7/site/Home.aspx

--
====================================
TaurArian [MVP] 2005-2008 - Australia
====================================
How to ask a question: http://support.microsoft.com/kb/555375
http://taurarian.mvps.org/index.htm
Emails will not be acknowledged - please post to the newsgroup so all may benefit.
Computer Maintenance: Acronis / Diskeeper / Paragon / Raxco
C.B. replied on 02-Mar-08 05:26 PM
bullmom,

Are you by any chance using the Comodo Firewall? It caused the same
problems for me starting in November of 2007. Although Comodo tells me the
problems have been fixed I found this to NOT be the case. I uninstalled it
and the problems went away. I will never install it again.
If you have the Comodo firewall I suggest you permanently uninstall it
and go with the native Windows firewall or something else. I cannot
recommend the ZoneAlarm firewall as it continues to be incompatible with
Vista.
You should disable your antivirus or security suite program before
attempting any update installation. Even then, it sometimes does not help
and you must uninstall it altogether. I haven't had any successes when I
only added the Windows Update and Microsoft Update applications to the
exceptions list.

C.B.


--
It is the responsibility and duty of everyone to help the underprivileged
and unfortunate among us.