Windows 7 - Unable to connect to any network shares.

Asked By vb on 11-Apr-07 12:20 PM
I am unable to connect to any share on my network - folders or printers.   I
can't even connect to \\127.0.0.1\any-share-on-my-local-notebook.  I get this
error, "The network location can not be reached..."

I'm using DHCP and have no static entries in my tcp/ip properties.   I can
release and renew my IP, but notice I have an IP addr, DNS, gateway, subnet
mask, etc... but no WINS.  All the other stations in my office doesn't have
this issue.  The same thing happens on any network I am on with this notebook.

I have never seen this before... any assistance would be helpful.  Thanks.


(repost.. sorry.  I put this in XP general earlier by mistake)




Chuck replied on 11-Apr-07 03:57 PM
Are you using WINS on your network?  DHCP?

Look at "ipconfig /all" from the problem computer, and from one other computer,
and compare the results.  And post the details here, so we can help you better.
http://nitecruzr.blogspot.com/2005/05/reading-ipconfig-and-diagnosing.html
http://nitecruzr.blogspot.com/2005/06/background-information-useful-in.html

--
Cheers,
Chuck, MS-MVP [Windows - Networking]
http://nitecruzr.blogspot.com/
Paranoia is not a problem, when it's a normal response from experience.
My        email         is          AT         DOT
actual       address    pchuck       mvps        org.
vb replied on 11-Apr-07 09:36 PM
Thanks for the reply Chuck.

I'm on DHCP and there is WINS.

This is the ipconfig /all result from my buggy laptop:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . : silabs.com
Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit
Ethernet Adapter
Physical Address. . . . . . . . . : 00-15-58-0A-21-C5
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.6.1.45
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.6.1.1
DHCP Server . . . . . . . . . . . : 10.6.1.19
DNS Servers . . . . . . . . . . . : x.x.x.x       (I can't post the
DNS of course
x.x.x.x         but it
comes out just fine)
x.x.x.x
Lease Obtained. . . . . . . . . . : Thursday, April 12, 2007 8:31:26
AM
Lease Expires . . . . . . . . . . : Saturday, April 14, 2007 8:31:26
AM

...and here's the results from another laptop, one that works just fine:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . : silabs.com
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Mobile
Connection
Physical Address. . . . . . . . . : 00-0D-60-8E-63-6A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.6.1.47
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.6.1.1
DHCP Server . . . . . . . . . . . : 10.6.1.19
DNS Servers . . . . . . . . . . . : x.x.x.x
x.x.x.x
x.x.x.x
Primary WINS Server . . . . . . . : x.x.x.x
Secondary WINS Server . . . . . . : x.x.x.x
Lease Obtained. . . . . . . . . . : Thursday, April 12, 2007 8:32:52
AM
Lease Expires . . . . . . . . . . : Saturday, April 14, 2007 8:32:52
AM

I don't get the WINS IPs...   the issue is more than an inability to resolve
names though.  I can't access shares even when I use \\x.x.x.x\sharename
Chuck replied on 11-Apr-07 11:24 PM
Is "silabs.com" a domain?  I'll bet that the working computers are setup for
domain, using WINS not broadcast, and NetBT is Disabled.
http://nitecruzr.blogspot.com/2006/07/advanced-windows-networking-using.html
http://nitecruzr.blogspot.com/2005/05/windows-xp-on-nt-domain.html
http://nitecruzr.blogspot.com/2005/05/address-resolution-on-lan.html

Since you munged, and trimmed your "ipconfig /all" logs, to be practically
useless (not even showing Node Type), I'm guessing your specific problem, so
you'll have to read the above articles, and follow all links.  But it will be
one of those problems.

--
Cheers,
Chuck, MS-MVP [Windows - Networking]
http://nitecruzr.blogspot.com/
Paranoia is not a problem, when it's a normal response from experience.
My        email         is          AT         DOT
actual       address    pchuck       mvps        org.
vb replied on 12-Apr-07 01:46 AM
ok... this bits were left out by mistake.

my notebook:

Windows IP Configuration

Host Name . . . . . . . . . . . . : NB0006930
Primary Dns Suffix  . . . . . . . : silabs.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : silabs.com


the working notebook:

Windows IP Configuration

Host Name . . . . . . . . . . . . : NB0006225
Primary Dns Suffix  . . . . . . . : silabs.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : silabs.com


The only real diff I find is that somehow my notebook will not display any
WINS info.   I even tried using a static IP...  filled in the DNS, WINS,
etc...  but when I run ipconfig /all, again it doesn't display any WINS info.